1. 解压缩 nginx-1.8.1.tar.gz

2. 解压缩 fastdfs-nginx-module-master.zip

3. 进入nginx-1.8.1目录中

4. 执行

然后就出现了错误。

解决办法:

  1.sudo apt-get update

  2.sudo apt-get install libpcre3 libpcre3-dev

  3.sudo apt-get install openssl libssl-dev

再次安装:

成功:

可是接下来执行 sudo make install 又出错了:

解决方法:

找到

CFLAGS = -pipe -O -W -Wall -Wpopinter-arith Wno-unused-parameter -Werror -g

然后删除 -Werror

再次sudo make install 安装完成

启动成功

以上就是本文的全部内容,希望对大家的学习有所帮助